Troubleshoot OpenLM Broker by EasyAdmin User Interface messages - OpenLM Software License Management
Israel +972 4 6308447      USA +1 619 831 0029         UK +44 203 807 9405         JAPAN +81 505 893 6263 担当:萩原         Japan Website

Troubleshoot OpenLM Broker by EasyAdmin User Interface messages

When opening the “License Servers” widget in OpenLM’s EasyAdmin user interface, you might see one of the following errors:

Description of each possible Broker error

How to troubleshoot each scenario: #

  1. BROKER DOWN: An OpenLM Broker had connected in the past but no connection is currently active with the license server machine and OpenLM Server.
  • Is the “OpenLM Broker” service running? Verify in Windows Services.
  • Has the hostname or IP changed? Note that the Broker IP or hostname in the OpenLM Server configuration tool needs to be exactly the same as it is shown in EasyAdmin.
  • Is it a network issue? This can be verified on 2 levels:
  1. In the configuration tool, click on Check Connectivity to OpenLM Server
  2. Check if a connection can be established with telnet.
  3. UNKNOWN: The connection has been established but the incoming data can not be identified
  • If this is a fresh configuration, this is a normal message which should change in about 3 minutes.
  • Is the same License Manager type configured in both the OpenLM Server configuration tool and the OpenLM Broker configuration tool?
  • Does the Broker query the license manager correctly? To verify:
  1. In the configuration tool, select Port → Commands → status then click on Execute. Does the result look OK?
  2. In the configuration tool, select Port → Commands → status then click on Execute. Does the result look OK?
  3. If the above commands did not work, make sure the path to the license manager executable is mapped correctly. Click the Commands node of the required port → click the “” button on the “Update path for commands” field → browse to the folder where the executable is located (usuallly in Program Files)→ click Open → click Update.
  4. Did the Port → Commands → data_inquiry command line path get mapped correctly? Try re-running the status and data_inquiry commands now.
  • Did you upgrade the license manager? A lot of times when upgrading the license manager the path will change. Refer to point C above.
  • Did you install a new license file? Make sure the Broker is pointing to the new license file under the Port → Advanced button.
  1. LM DOWN
  • The license manager is down. Check if the license manager is running and start it.

 

Other things to check: #

  1. Which version are you using?
  2. If you’ve upgraded to the latest version and it suddenly stopped working, the broker.xml file may have been corrupted. Uninstall, clean any trace files and do a fresh install.
  3. When using RMS, is the path pointing to lsmon.exe/lservnt.exe? Do they exist in your environment? If not, please contact support@openlm.com.

Powered by BetterDocs